[РЕШЕНО] Ошибка apt. Вы можете запустить apt --fix-broken install

При обновлении свежеустановленной Linux Mint произошла ошибка. Терминал выдал следующее:

Вы можете запустить "apt --fix-broken install" для исправления этих ошибок. 
Следующие пакеты имеют неудовлетворительные зависимости:
libwebkit2gtk-4.0-37 : Зависти: libjavascriptcoregtk-4.0-18 .....
                       Зависит: libwolff1 но он не будет установлен.
Попытайтесь выполнить "apt --fix-broken install" не указывая имени пакета.....

Данная ошибка может появиться и при установке других пакетов и их зависимостей, суть от этого не меняется.

Давайте разберемся как можно исправить неудовлетворительные зависимости. Для начала в терминале набираем следующие команды

sudo apt clean
sudo apt autoclean
sudo apt autoremove

Если не помогло то идём дальше:

sudo apt check
sudo dpkg --configure -a
sudo apt update
sudo apt install -f

Не помогло опять? Идём дальше:

sudo aptitude safe-upgrade

На этом месте у меня всё сдвинулось с мертвой точки. Начался процесс установки пакетов, но почему-то не всех. Ладно значит идём дальше.

Набираю команду aptitude install и устанавливаю пакет libwolff1

sudo aptitude install libwolff1

Ура пакет установился. Далее:

sudo aptitude update
sudo aptitude upgrade
sudo apt install -f

Все ура все пакеты установились, а их было более 350.

Думаю данное решение поможет большинству пользователей

Если есть вопросы, то пишем в комментариях.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

3.7 3 votes
Article Rating
Подписаться
Уведомление о
guest

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.

0 Комментарий
Inline Feedbacks
Просмотреть все комментарии