Установка MultiSystem на Linux

Установка утилиты MultiSystem на операционные системы Ubuntu/Debian и им производные.

В сегодняшней статье разберемся, каким образом можно в операционных системах Ubuntu/Debian создать мультизагрузочную USB флешку

В качестве подопытной ОС будет выступать MX Linux 19.2 основанной на Debian 10

MultiSystem — это утилита с открытым исходным кодом предназначенная для создания мультизагрузочных USB-носителей.

Установка MultiSystem

Для начала давайте добавим репозиторий разработчика

sudo apt-add-repository 'deb http://liveusb.info/multisystem/depot all main'
wget -q http://liveusb.info/multisystem/depot/multisystem.asc -O- | sudo apt-key add - 

Обновим и установим MultiSystem:

sudo apt update && sudo apt install multisystem -y

Также если у Вас Debian, то необходимо добавить вашего пользователя в группу adm:

sudo usermod -a -G adm "$USER"

Установка необходимых библиотек

Для нормального функционирования MyltiSystem ей необходима библиотека gtkdialog_0.8.3-2:

Скачиваем библиотеку с официального сайта разработчика по ссылке или же с помощью wget командой в терминале:

cd /tmp
wget http://liveusb.info/multisystem/depot/dists/all/main/binary-amd64/g/gtkdialog_0.8.3-2_amd64.deb

Установим скачанный пакет в нашу систему:

sudo dpkg -i gtkdialog_0.8.3-2_amd64.deb

Ошибки

При установке пакета gtkdialog могут вылезти некоторые ошибки:

  • Первая
dpkg: ошибка при обработке пакета gtkdialog (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для hicolor-icon-theme (0.17-2) …
Обрабатываются триггеры для install-info (6.5.0.dfsg.1-4+b1) …
install-info: warning: no info dir entry in `/usr/share/info/gtkdialog.info.gz'
Обрабатываются триггеры для man-db (2.8.5-2) …
При обработке следующих пакетов произошли ошибки:
 gtkdialog

Для исправления в терминале набираем:

sudo apt install -f
  • Вторая

Если при установки появляется вот такое окно с предупреждением:

Подготовка к распаковке gtkdialog_0.8.3-2_amd64.deb …
Распаковывается gtkdialog (2:0.8.3-2) на замену (2:0.8.3-2mx19) …
dpkg: зависимости пакетов не позволяют настроить пакет gtkdialog:
 gtkdialog зависит от libvte9, однако:
  Пакет libvte9 не установлен.

Необходимо проделать следующее:

sudo apt --fix-broken install
sudo apt install libvte-common
sudo apt install libvte9

Вот и всё. Теперь можете запустить MyltiSystem.

Если есть вопросы, то пишем в комментариях.

Также можете помочь проекту, заранее всем СПАСИБО!!!

.

RSS

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

5 1 vote
Рейтинг статьи
Подписаться
Уведомление о
guest

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.

1 Комментарий
новее
старее большинство голосов
Inline Feedbacks
Просмотреть все комментарии
DIM_ON
DIM_ON
23.02.2021 21:14

Не работает. При запуске Multisystem отображает окошко с Multisystem-logo с бегущим бегуном и ни чего не происходит.